Symptom
After installation of the integration framework for SAP Business One
(B1i), system entries for the SAP Business One company databases are not
available in SLD.
Reproducing the issue
Scenario:
- Install the integration
framework for SAP Business One (B1i).
- Logon to the integration
framework and select SLD.
Expected Behavior:
In the navigation tree, the integration framework displays entries for
the SAP Business One company databases.
Actual Behavior:
In the navigation tree, no entries are available for the SAP
Business One company databases.
Cause
It is a system configuration issue or you have reinstalled the
integration framework.
Solution
Option 1: use B1 Setup Tool to create the system entries:
- Go integration
framework, choose Tools → Troubleshooting Tools → Choose "B1
Setup" as Functional Group → Submit!
- B1 Company DBs section
displays "Inconsistencies between B1 SLSP/SLSPP and framework
SLD".
- Click [Sync] button and
choose "Create SysId in B1i SLD" to generate system entries in
B1i SLD.
Option 2: manually create the system entries, follow the steps
below:
- In the integration
framework, choose SLD, select the SBO-COMMON
system and click Copy.
The integration framework creates a new system entry in SLD.
- Select the new system ID,
select Edit, and change the following values:
- Name: Enter a name for the system ID
- b1Server: Enter the same value as defined in the SAP
Business One client. Choose the Company window → Current
Server, for example, "10.98.75.83" or
"10.97.159.92:30015".
- company: Enter the company database name
- licenseServer: Enter the same value as defined in the server
tool
- password: Enter the password for the "B1i" SAP
Business One user, defined in the SAP Business One client.
- url: Make sure that the server name and the database name
are correct.
- Click Save, wait
for a minute and click Test Connection in the B1DI and
in the JDBC sections to make sure that the connection
settings are correct.
- Optional: In the integration
framework, choose Tools → Troubleshooting.
Select B1 Setup, click Submit, in
the B1 Company DBs section, click the Sync button,
select Create SysId in B1 SLSP/SLSPP Tables, wait and
click the Regenerate button until all SAP Business One
company databases display the in sync status.
If you use the SAP Business One dashboard solution, assign the new
system ID to the dashboard packages:
- In the integration
framework, choose Scenarios → Setup, in the Scenario
Package Identifier field, select sap.Xcelsius,
and click Deactivate.
Click Sender, select Define Sender List and
select the new system ID from the list.
Save your settings and click Active.
- In the integration
framework, choose Scenarios → Setup, in the Scenario
Package Identifier field, select sap.XcelsiusPortal, and
click Deactivate.
Click Sender, select Define Sender List and
select the new system ID from the list.
Save your settings and click Active.
If you use the SAP Business One mobile solution, make sure that the
below settings are consistent:
- In the integration
framework, choose SLD → B1i Server , select the new
System ID and check the b1Server entry.
- In the integration
framework, choose SLD → B1i Server, select the WSforMobile system
and in the WSAR section, check the associatedSrvIP entry.
Product
Product or Product Version
B1 INTERCOMPNY INTEGRATION 2.0
SAP B1 10.0 FOR SAP HANA
SAP B1 9.3 FOR SAP HANA
SAP BUSINESS ONE 10.0
SAP BUSINESS ONE 9.3
This document is referenced by :
WDF 1844555 - Troubleshooting Intercompany Integration Solution for SAP Business One
WDF 1602674 - SAP Business One mobile app for iOS - Troubleshooting and Compatibility Information
WDF 1924930 - SAP Business One mobile app for Android - Troubleshooting and compatibility information
WDF 1619422 - Troubleshooting SAP Business One Dashboard/Cockpit